porno porno izle rokettube
Ergebnis 1 bis 9 von 9

Thema: Kein Mailversand mit Zend im Rahmen von Shopware

  1. #1
    Nwn
    Nwn ist offline
    Neuer Benutzer
    Registriert seit
    10.08.2016
    Beiträge
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard Kein Mailversand mit Zend im Rahmen von Shopware

    Sehr geehrte Community,

    ich brauch dringend eure Hilfe. Das Unternehmen in dem ich arbeite, hat eine Website mit dem Shopsystem von Shopware erstellt.
    Jetzt gehen jedoch leider keine Bestellbestätigung per Mail raus. Ich hab schon verschiedene Mailhoster probiert, aber keiner funktioniert.
    Ich bekomm jedes mal die Fehlermeldung:

    core.ERROR: Could not send order mail for ordernumber 20126 to address meinemailadresse {"exception":"[object] (Zend_Mail_Transport_Exception(code: 0): Unable to send mail. at /opt/lampp/htdocs/engine/Library/Zend/Mail/Transport/Sendmail.php:137)"}

    Kann mir zumindest jemand sagen, wie ich dem Fehler auf die Schliche kommen kann?

    Viele Grüße

    Jörg-Michael

    P.S. Der Support von Shopware ist leider nach 3 Wochen keine Hilfe und hat das Problem abgewunken

  2. #2
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.506
    Thanks
    3
    Thanked 349 Times in 280 Posts

    Standard

    Willkommen im Forum!
    Zitat Zitat von Nwn Beitrag anzeigen
    Ich hab schon verschiedene Mailhoster probiert, aber keiner funktioniert.
    Was hast du hier probiert? Die Mail abzurufen? Das Versenden kann es nicht sein, denn das läuft – laut deiner Konfiguration – über deinen Server.

    Zitat Zitat von Nwn Beitrag anzeigen
    Ich bekomm jedes mal die Fehlermeldung:

    core.ERROR: Could not send order mail for ordernumber 20126 to address meinemailadresse {"exception":"[object] (Zend_Mail_Transport_Exception(code: 0): Unable to send mail. at /opt/lampp/htdocs/engine/Library/Zend/Mail/Transport/Sendmail.php:137)"}
    Die Fehlermeldung sagt nur aus, dass keine E-Mail über die Standardfunktion „mail“ von PHP versendet werden kann.

    Daher einfach mal die Standardfunktion „mail“ ohne „Shopware“ testen.
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

  3. #3
    Nwn
    Nwn ist offline
    Neuer Benutzer
    Registriert seit
    10.08.2016
    Beiträge
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Doch das Versenden ist nicht möglich. Ich weiß nicht ob es was hilft, aber als ich GMAIL probiert hatte, bekam ich ne Meldung, dass der Zugriff auf SMTP blockiert wurde:
    Anmeldeversuch verhindert

    Hallo Jörg-Michael,
    Soeben hat jemand versucht, sich mit Ihrem Google-Konto in einer App anzumelden, die die modernen Sicherheitsstandards nicht erfüllt.
    Details:
    Montag, 1. August 2016 21:15 (Mitteleuropäische Sommerzeit)
    Prag, Tschechische Republik*
    Wir empfehlen Ihnen dringend, für den Zugriff auf Ihr Konto eine sichere App zu verwenden, wie beispielsweise Gmail. Alle Apps von Google entsprechen diesen Sicherheitsstandards. Die Verwendung einer weniger sicheren App könnte Ihr Konto anfällig für Angriffe machen. Weitere Informationen
    EDIT: Ich hab anschließend die Verbindung als sicher eingestuft, nun bekomm ich kein Warnhinweis mehr, aber E-Mails werden trotzdem nicht versendet

    Wie kann ich die Standardfunktion testen?
    Vielen Dank schon mal für die zügige Antwort

    P.S. Ich hab es jetzt nochmal im Debug-Modus versucht und bekomm folgende Fehlermeldung:

    Unable to send mail. in engine/Library/Zend/Mail/Transport/Sendmail.php on line 137

    Stack trace:

    #0 engine/Library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Sendmail->_sendMail()
    #1 engine/Library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Enlight_Components_Mail))
    #2 engine/Library/Enlight/Components/Mail.php(332): Zend_Mail->send(NULL)
    #3 engine/Shopware/Controllers/Frontend/Account.php(473): Enlight_Components_Mail->send()
    #4 engine/Shopware/Controllers/Frontend/Account.php(433): Shopware_Controllers_Frontend_Account->sendResetPasswordConfirmationMail('joerg.sabbah@g m...')
    #5 engine/Library/Enlight/Controller/Action.php(159): Shopware_Controllers_Frontend_Account->passwordAction()
    #6 engine/Library/Enlight/Controller/Dispatcher/Default.php(523): Enlight_Controller_Action->dispatch('passwordAction')
    #7 engine/Library/Enlight/Controller/Front.php(226): Enlight_Controller_Dispatcher_Default->dispatch(Object(Enlight_Controller_Request_Reques tHttp), Object(Enlight_Controller_Response_ResponseHttp))
    #8 engine/Shopware/Kernel.php(176): Enlight_Controller_Front->dispatch()
    #9 vendor/symfony/http-kernel/HttpCache/HttpCache.php(487): Shopware\Kernel->handle(Object(Symfony\Component\HttpFoundation\Re quest), 1, true)
    #10 engine/Shopware/Components/HttpCache/AppCache.php(255): Symfony\Component\HttpKernel\HttpCache\HttpCache->forward(Object(Symfony\Component\HttpFoundation\R equest), true, NULL)
    #11 vendor/symfony/http-kernel/HttpCache/HttpCache.php(258): Shopware\Components\HttpCache\AppCache->forward(Object(Symfony\Component\HttpFoundation\R equest), true)
    #12 vendor/symfony/http-kernel/HttpCache/HttpCache.php(275): Symfony\Component\HttpKernel\HttpCache\HttpCache->pass(Object(Symfony\Component\HttpFoundation\Requ est), true)
    #13 engine/Shopware/Components/HttpCache/AppCache.php(133): Symfony\Component\HttpKernel\HttpCache\HttpCache->invalidate(Object(Symfony\Component\HttpFoundatio n\Request), true)
    #14 vendor/symfony/http-kernel/HttpCache/HttpCache.php(206): Shopware\Components\HttpCache\AppCache->invalidate(Object(Symfony\Component\HttpFoundatio n\Request), true)
    #15 engine/Shopware/Components/HttpCache/AppCache.php(114): Symfony\Component\HttpKernel\HttpCache\HttpCache->handle(Object(Symfony\Component\HttpFoundation\Re quest), 1, true)
    #16 shopware.php(101): Shopware\Components\HttpCache\AppCache->handle(Object(Symfony\Component\HttpFoundation\Re quest))
    #17 {main}
    Geändert von Nwn (10.08.2016 um 15:06 Uhr)

  4. #4
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.506
    Thanks
    3
    Thanked 349 Times in 280 Posts

    Standard

    Stopp mal an der Stelle!
    Versuche nicht irgendetwas, denn das bringt absolut nichts. Daher von vorn:

    - Du hast ein Shopsystem laufen, also auch einen entsprechenden Hosting-Anbieter oder einen eigenen Server aufgesetzt.
    - Beim Hosting-Anbieter oder auf deinem Server sollte auch der Mail-Versand verfügbar / eingerichtet sein.
    - Das Shopsystem ist momentan so konfiguriert, dass die Standardfunktion von PHP zum Mail-Versand verwendet wird –*denn „Zend_Mail_Transport_Sendmail“ nutzt diese intern.

    Daher der Rückschluss, dass du zuerst den Mail-Versand ohne das Shopsystem testen sollst. Dies kannst du mit einfachem PHP durchführen. (Siehe dazu die Doku.)
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

  5. #5
    Nwn
    Nwn ist offline
    Neuer Benutzer
    Registriert seit
    10.08.2016
    Beiträge
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    So ich hab das jetzt mal versucht mit:

    <?php
    $empfaenger = "empfängermailadresse";
    $betreff = "Die Mail-Funktion";
    $from = "From: Nils Reimers <absendermailadresse>";
    $text = "Hier lernt Ihr, wie man mit PHP Mails verschickt";

    mail($empfaenger, $betreff, $text, $from);
    ?>
    Die zugehörige Log dazu:

    [10-Aug-2016 20:33:37 Europe/Berlin] mail() on [/opt/lampp/htdocs/engine/Library/Zend/Mail/Transport/Sendmail.php:106]: To: empfängermailadresse -- Headers: From: Domhage Bcc: absendermailadresse Date: Wed, 10 Aug 2016 20:33:37 +0200 Content-Type: multipart/alternative; boundary="=_3e9e0b4468aeeb76664895b925bac283" MIME-Version: 1.0
    Jedoch ist die Mail nicht angekommen. Wie konfiguriere ich das mail() so, dass ne mail an nen externen Server rausgehen? Ich habe nichts gefunden, wo ich irgendwelche Zugangsdaten eintragen kann.

    Vielen Dank für die Hilfe!

  6. #6
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.506
    Thanks
    3
    Thanked 349 Times in 280 Posts

    Standard

    Zitat Zitat von Nwn Beitrag anzeigen
    Wie konfiguriere ich das mail() so, dass ne mail an nen externen Server rausgehen? Ich habe nichts gefunden, wo ich irgendwelche Zugangsdaten eintragen kann.
    Ich sehe drei Möglichkeiten:

    1. Du beschäftigst dich mit „sendmail“, aber davon würde ich dir abraten, denn scheinbar fehlt dir einfach das Basiswissen.
    2. Ein Server-Administrator richtet dir alles ein.
    3. Aber die einfachste Variante wird sein, du passt die Konfiguration von „Shopware“ richtig an. Denn die Verwendung von „sendmail“ ist kein Muss. Sie in der Doku von „Shopware“ nach SMTP.
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

  7. #7
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.506
    Thanks
    3
    Thanked 349 Times in 280 Posts

    Standard

    Ich habe das Thema verschoben, denn das Problem liegt weit ab vom ZF und betrifft eher Server- und/oder Shopsystem-Konfiguration.
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

  8. #8
    Nwn
    Nwn ist offline
    Neuer Benutzer
    Registriert seit
    10.08.2016
    Beiträge
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Vielen lieben Dank für die Mühen und Entschuldigung dass das Thema in der falschen Rubrik war.
    Die Vorschläge 2 und 3 sind die, die ich natürlich bereits in Angriff genommen und ausgeschöpft habe.
    Ich habe mittlerweile an die 30 verschiedene Konfigurationen vom Mailer in Shopware mit verschiedenen Mailservern in den letzten Monaten probiert
    und der Support winkt ab und teilt nur mit, dass es am Mailserver liegt und das kein Problem mit Shopware vorliegt.
    Ich weiß einfach nicht weiter wie ich mit dem ganzen Problem überhaupt noch umgehen soll

  9. #9
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.506
    Thanks
    3
    Thanked 349 Times in 280 Posts

    Standard

    Zitat Zitat von Nwn Beitrag anzeigen
    Ich habe mittlerweile an die 30 verschiedene Konfigurationen vom Mailer in Shopware mit verschiedenen Mailservern in den letzten Monaten probiert
    Bitte beantworte uns mal diese Frage: Wer hat denn den Web-Server aufgesetzt bzw. bei welchem Anbieter hast du einen Server oder Hosting-Anbieter gebucht?
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

Ähnliche Themen

  1. Problem bei Mailversand mit Bild/Anhang
    Von Matus von Matushausen im Forum ZF2 Core
    Antworten: 1
    Letzter Beitrag: 03.07.2014, 15:05
  2. Antworten: 2
    Letzter Beitrag: 27.11.2013, 16:39
  3. Wie entsehen die farbigen Rahmen der Input Felder
    Von Sunny im Forum ZF2 Einsteigerfragen
    Antworten: 1
    Letzter Beitrag: 16.04.2013, 11:22
  4. Antworten: 1
    Letzter Beitrag: 02.01.2013, 14:04
  5. Antworten: 10
    Letzter Beitrag: 16.03.2011, 14:12

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •