turk porno porno escort rokettube
Ergebnis 1 bis 3 von 3

Thema: unterminated entity reference XML Zeichen "&" wird nicht gespeichert

  1. #1
    Neuer Benutzer
    Registriert seit
    21.07.2009
    Beiträge
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard unterminated entity reference XML Zeichen "&" wird nicht gespeichert

    was:
    ich lese von einer fremden Seite die Inhalt(content) aus...
    anschließend versuche ich den Inhalt in XML zu parsen, dies funktionier auch soweit alles... allerdings bekomme ich Warnings:
    Code:
    Warning: SimpleXMLElement::addChild() [simplexmlelement.addchild]: unterminated entity reference medium=Internet&nr=21477 in xxxxx\library\Zend\Config\Writer\Xml.php on line 122
    meine XML Datei wird erstellt, an einigen Stellen sind URL´s die ungefähr so aussehen sollen "/index.php?obj=stellenangebot&medium=Internet&nr=21477"
    aber das tut es nicht, es sieht so aus "/index.php?obj=stellenangebot" hier wird abgebrochen

    wie kann ich diesen Problem umgehen?

  2. #2
    Erfahrener Benutzer Avatar von SeKrebs
    Registriert seit
    05.02.2011
    Beiträge
    1.599
    Thanks
    1
    Thanked 58 Times in 46 Posts

    Standard

    Aus Sicht des XML-Parsers ist das auch richtig, schließlich ist es in der Form kein gültiges XML. "&" leitet Entities ein, die dann aber mit ";" mit abgeschlossen werden müssen, was sie hier nicht sind, was aber sicherlich hier auch nicht gewollt ist. Konkret: Escapen (per Entity oder wasauchimmer), oder direkt als CDATA schreiben.
    "KingCrunchs kleine Welt" -- Blog
    The problem with rats leaving a sinking ship is that they usually do it by gnawing holes in the bottom.

  3. #3
    Neuer Benutzer
    Registriert seit
    21.07.2009
    Beiträge
    27
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Danke, ich escape es einfach

Ähnliche Themen

  1. Antworten: 14
    Letzter Beitrag: 12.01.2012, 15:24
  2. Zend_Cache: "\tmp" wird nicht gefunden
    Von itsame69 im Forum Core
    Antworten: 7
    Letzter Beitrag: 09.06.2011, 10:52
  3. Antworten: 19
    Letzter Beitrag: 21.03.2011, 16:28
  4. "setLayout" -> CSS wird nach Weiterleitung nicht erkannt
    Von Powers im Forum Einsteigerfragen
    Antworten: 6
    Letzter Beitrag: 27.08.2010, 16:39
  5. Antworten: 7
    Letzter Beitrag: 25.04.2008, 14:06

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •