turk porno porno escort rokettube
Ergebnis 1 bis 10 von 10

Thema: Kapitel 04, Galileo, Installation der Projektdateien schlägt fehl

  1. #1
    Neuer Benutzer
    Registriert seit
    03.02.2015
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard Kapitel 04, Galileo, Installation der Projektdateien schlägt fehl

    Hallo Ralf Eggert,

    nachdem ich die Projektdateien von Kapitel 04 geclont habe und den Composer geupdated habe, schlägt der Befehl "php composer.phar install" fehl.

    Ich erhalte auf der Konsole die Fehlermeldung

    "Loading composer repositories with package information
    Installing dependencies (including require-dev)
    - Installing zendframework/zendxml (1.0.0)
    [Zend Utils 2015-02-02T21:57:02] Process 9328 has exited unexpectedly. Minidump
    is at C:\Users\Stefan\AppData\Local\Temp\zend_dump\p9328 .mdmp."

    und ein Dialogfenster mit der Meldung "CLI funktiniert nicht mehr".

    Hast Du einen Tip wo ich mit der Fehlersuche beginnen könnte?

    Danke und viele Grüße

    Stefan

  2. #2
    Erfahrener Benutzer Avatar von Ralf
    Registriert seit
    14.12.2006
    Beiträge
    450
    Thanks
    0
    Thanked 47 Times in 37 Posts

    Standard

    Hallo Stefan,

    ich habe das eben auch einmal ausprobiert:

    Code:
    ralf@ralf-HP-2013:~$ cd /home/devhost/
    ralf@ralf-HP-2013:/home/devhost$ git clone https://github.com/ZF2Buch/kapitel04.git buchtest04
    Klone nach 'buchtest04'...
    remote: Counting objects: 125, done.
    remote: Total 125 (delta 0), reused 0 (delta 0)
    Empfange Objekte: 100% (125/125), 498.34 KiB | 288.00 KiB/s, done.
    Löse Unterschiede auf: 100% (26/26), done.
    Prüfe Konnektivität... Fertig.
    ralf@ralf-HP-2013:/home/devhost$ cd buchtest04/
    ralf@ralf-HP-2013:/home/devhost/buchtest04$ php composer.phar selfupdate
    Warning: This development build of composer is over 30 days old. It is recommended to update it by running "composer.phar self-update" to get the latest version.
    Updating to version f1a2f5b1d038e117b14d802f766be69ebcdd7bb5.
        Downloading: 100%         
    ralf@ralf-HP-2013:/home/devhost/buchtest04$ php composer.phar install
    Loading composer repositories with package information
    Installing dependencies (including require-dev)
      - Installing zendframework/zendxml (1.0.0)
        Loading from cache
    
      - Installing zendframework/zendframework (2.1.6)
        Downloading: 100%         
    
    zendframework/zendframework suggests installing doctrine/common (Doctrine\Common >=2.1 for annotation features)
    zendframework/zendframework suggests installing ircmaxell/random-lib (Fallback random byte generator for Zend\Math\Rand if OpenSSL/Mcrypt extensions are unavailable)
    zendframework/zendframework suggests installing pecl-weakref (Implementation of weak references for Zend\Stdlib\CallbackHandler)
    zendframework/zendframework suggests installing zendframework/zendpdf (ZendPdf for creating PDF representations of barcodes)
    zendframework/zendframework suggests installing zendframework/zendservice-recaptcha (ZendService\ReCaptcha for rendering ReCaptchas in Zend\Captcha and/or Zend\Form)
    Writing lock file
    Generating autoload files
    ralf@ralf-HP-2013:/home/devhost/buchtest04$
    Die Installation hat reibungslos geklappt. Die Fehlermeldung kannte ich bisher auch noch nicht. Hast du mal versucht, dass Ganze zu wiederholen?

    Gruß,

    Ralf

  3. #3
    Neuer Benutzer
    Registriert seit
    03.02.2015
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Hallo Ralf,

    ich habe das vorgestern, gestern und heute ausprobiert. Das Ganze auch in Kapitel 02 und 03.

    Leider immer die gleiche Fehlermeldung.

    Ich arbeite mit Win 8.1 (64bit) und nutze PHP 5.6.4 (cli).

    Gruß

    Stefan

  4. #4
    Erfahrener Benutzer Avatar von Ralf
    Registriert seit
    14.12.2006
    Beiträge
    450
    Thanks
    0
    Thanked 47 Times in 37 Posts

    Standard

    Hallo Stefan,

    also ich habe PHP 5.5.9 unter Ubuntu. Aber generell sollte es bei dir auch funktionieren. Hast du mal versucht, die offizielle ZendSkeletonApplication zu installieren? Klappt das auch nicht?

    https://github.com/zendframework/Zen...tonApplication

    Gruß,

    Ralf

  5. #5
    Neuer Benutzer
    Registriert seit
    03.02.2015
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Die offizielle ZendSkeleton funktioniert problemlos.

  6. #6
    Erfahrener Benutzer Avatar von Ralf
    Registriert seit
    14.12.2006
    Beiträge
    450
    Thanks
    0
    Thanked 47 Times in 37 Posts

    Standard

    Hallo Stefan,

    das ist dann in der Tat mehr als sonderbar. Ich habe hier leider kein Windows 8.1 Rechner zum Testen. Nur am Wochenende kann ich einen Windows 7 Rechner zum Testen verwenden. So kann ich das leider nur schlecht nachstellen.

    Hast du mal in die Datei C:\Users\Stefan\AppData\Local\Temp\zend_dump\p9328 geschaut, was dort drin steht?

    Und hast du in der composer.json einmal die Angabe für das Zend Framework von 2.1.* auf 2.2.* geändert und dann die Installation nochmal gestartet?

    Gruß,

    Ralf

  7. #7
    Neuer Benutzer
    Registriert seit
    03.02.2015
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Hallo Ralf,

    in der composer.json wird bereits auf die Version 2.2.* verwiesen. Der Inhalt der Datei p9328 sieht ziemlich binär aus und sagt mir nicht viel.

    Ich kann leider keine Tests mit einem anderen Rechner machen, weil ich im Urlaub bin und nur das Laptop dabei habe.

    Hast Du eventuell eine Möglichkeit die Installation mit PHP 5.6* zu testen?

    Viele Grüße

    Stefan

  8. #8
    Erfahrener Benutzer Avatar von Ralf
    Registriert seit
    14.12.2006
    Beiträge
    450
    Thanks
    0
    Thanked 47 Times in 37 Posts

    Standard

    Hallo Stefan

    leider kann ich das auch so ohne weiteres nicht testen. Bin selber gerade unterwegs und will mein laufendes System nicht einfach so aufs Spiel setzen durch Neuinstallationen ohne vorheriges Backup.

    Konnte denn jemand anderes das Problem nachstellen?

    Gruß,

    Ralf

  9. #9
    Neuer Benutzer
    Registriert seit
    03.02.2015
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    L?cheln

    Hallo Ralf,

    ich habe mir jetzt mal PHP 5.6.5 heruntergeladen und diese Version für die Ausführung von

    Code:
    php composer.phar install
    genutzt.

    Damit klappt die Installation und die Listings zum Buch funktionieren.

    Damit hat sich für mich das Problem erledigt.

    Viele Grüße

    Stefan

  10. #10
    Erfahrener Benutzer Avatar von Ralf
    Registriert seit
    14.12.2006
    Beiträge
    450
    Thanks
    0
    Thanked 47 Times in 37 Posts

    Standard

    Hallo Stefan,

    danke für die Rückmeldung. Zusammenfassend hat die Installation mit PHP 5.6.4 nicht geklappt, aber mit PHP 5.6.5. Gut zu wissen für zukünftige Fragesteller, auch wenn immer noch unklar, woran es konkret gelegen haben könnte.

    Danke und Gruß,

    Ralf

Ähnliche Themen

  1. Controller Factory Interface, Kapitel 8.6.4 [Galileo]
    Von fitti im Forum Zend Framework 2 Buch
    Antworten: 11
    Letzter Beitrag: 21.03.2014, 13:14
  2. Kapitel 18/19 [Galileo-Auflage]
    Von matz im Forum Zend Framework 2 Buch
    Antworten: 2
    Letzter Beitrag: 07.10.2013, 12:29
  3. Antworten: 0
    Letzter Beitrag: 06.05.2013, 18:19
  4. PHPUnit schlägt fehl
    Von Zocki im Forum Testing & Deployment
    Antworten: 4
    Letzter Beitrag: 25.08.2011, 23:11
  5. Zend_PDF - Anzeigen der PDF schlägt fehl
    Von Schnatterinchen im Forum Einsteigerfragen
    Antworten: 4
    Letzter Beitrag: 30.06.2011, 17:34

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •