turk porno porno escort rokettube
Ergebnis 1 bis 3 von 3

Thema: Parameter werden nicht angehängt

  1. #1
    Erfahrener Benutzer
    Registriert seit
    11.09.2007
    Beiträge
    251
    Thanks
    0
    Thanked 9 Times in 3 Posts

    Standard Parameter werden nicht angehängt

    Hallo,

    bei dem folgenden Request wird der Parameter color nicht angehängt.
    Mache ich etwas falsch?

    PHP-Code:
    $client = new Client($clientUrl$config );
    $client->setMethod('POST');
    $client->setHeaders(array('Content-Type'  => 'application/xml'));
    $client->setParameterPost(array('color' => 'red'));
    $response $client->send(); 
    Normalerweise sollte ja so etwas raus kommen:

    POST /test/api/car?color=red

    PHP-Code:
    $send $client->getLastRawRequest();
    Debug::dump($send); 
    Gibt mir folgendes aus:
    ...
    string(539) "POST /test/api/car HTTP/1.1"
    ...

    Danke im Voraus.

  2. #2
    Hec
    Hec ist offline
    Neuer Benutzer
    Registriert seit
    12.02.2014
    Beiträge
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Werden bei POST die Parameter überhaupt an die URL angehängt?
    Ist das nicht bloß bei GET so?

    Beste Grüße,
    Sven

  3. #3
    Erfahrener Benutzer
    Registriert seit
    21.07.2009
    Beiträge
    102
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Post Parameter kannst du dir zb in einer Entwicklerkonsole ansehen, die siehst du nicht in der url wie Hec schon schrieb.
    Um die in die Url zu bekommen musst die GET anstatt POST verwenden.

    lg

Ähnliche Themen

  1. fremdes javascript angehängt
    Von gingin im Forum Offtopic
    Antworten: 6
    Letzter Beitrag: 24.11.2012, 11:08
  2. views werden nicht angezeigt
    Von vitaminb im Forum Einsteigerfragen
    Antworten: 2
    Letzter Beitrag: 15.06.2010, 13:07
  3. Zend_Curreny - Angehängte 1 bei keinem Symbol
    Von Pwner im Forum Lokalisierung & Internationalisierung
    Antworten: 0
    Letzter Beitrag: 25.05.2009, 12:19
  4. Übersetzungsdateien werden nicht erkannt
    Von tebe im Forum Lokalisierung & Internationalisierung
    Antworten: 12
    Letzter Beitrag: 29.11.2008, 13:22
  5. request->getParam('id') empfängt nur GET, kein POST!
    Von deklarmart im Forum Einsteigerfragen
    Antworten: 5
    Letzter Beitrag: 22.02.2008, 15:23

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •