turk porno porno escort rokettube
Ergebnis 1 bis 4 von 4

Thema: Zend View Helper und Controller Plugins werden nicht gefunden

  1. #1
    Neuer Benutzer
    Registriert seit
    12.02.2019
    Beiträge
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard Zend View Helper und Controller Plugins werden nicht gefunden

    Hallo zusammen.

    ich habe vor kurzem ein Update von ZF2 zu ZF3 via composer gemacht.
    Soweit läuft alles gut, die Migration war relativ aufwändig aber machbar.

    Was mich nur stört ist, dass scheinbar sämtliche von Haus aus mitgelieferten View Helper und Controller Plugins nicht registiert werden.
    zB Flashmessenger oder FilePrg.

    Ich habe gleiche sämtliche Module installiert, also auch zB zebd-mvc-plugin-prg doch die Module.php des Moduls wird scheinbar nie aufgerufen und entsprechend die Konfiguration nicht geladen.

    Man muss dazu sagen dass in meiner App die Module.php NICHT im src Folder des Moduls ist, so wie es bei den ZF3 Modulen der Fall ist.
    Evtl muss ich dem Composer noch beibringen dass er auch im src Folder nach Module.php's zu suchen hat?

    Viele Grüße und vielen Dank im Voraus!

  2. #2
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.548
    Thanks
    4
    Thanked 357 Times in 288 Posts

    Standard

    Willkommen im Forum!
    Zitat Zitat von PeterHerbert1 Beitrag anzeigen
    Was mich nur stört ist, dass scheinbar sämtliche von Haus aus mitgelieferten View Helper und Controller Plugins nicht registiert werden.
    zB Flashmessenger oder FilePrg.
    Das sind schon mal nicht sämtliche View-Helfer und Controller-Plugins, sondern nur 4 oder so!

    Zitat Zitat von PeterHerbert1 Beitrag anzeigen
    Ich habe gleiche sämtliche Module installiert…
    Hier reicht es, dass entsprechende „Metapackage“ mit dem Namen „zend-mvc-plugins“ zu verwenden: https://github.com/zendframework/zend-mvc-plugins

    Zitat Zitat von PeterHerbert1 Beitrag anzeigen
    …doch die Module.php des Moduls wird scheinbar nie aufgerufen und entsprechend die Konfiguration nicht geladen.
    Dann sind die Module höchstwahrscheinlich in der Anwendung nicht registriert. Wie bei allen Modulen erfolgt dies in: „config/application.config.php“ oder „config/module.config.php“

    Oder du verwendest den „Component-Installer“, welcher als Composer-Plugin daherkommt und auch gleich die Registrierung übernimmt: https://docs.zendframework.com/zend-...ent-installer/
    Geändert von Kaiuwe (12.02.2019 um 18:40 Uhr)
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

  3. #3
    Neuer Benutzer
    Registriert seit
    12.02.2019
    Beiträge
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Standard

    Hallo Kaiuwe,

    vielen Dank für die schnelle Antwort

    Ich habe nun nochmal etwas rumprobiert, es lag an daran, dass meine config/module.config.php scheinbar nie geladen wird. Schreibe ich die Module in meine application.config funktionierts!

    Weißt du woran es mit der module.config liegen kann?

  4. #4
    Super-Moderator Avatar von Kaiuwe
    Registriert seit
    30.12.2006
    Beiträge
    5.548
    Thanks
    4
    Thanked 357 Times in 288 Posts

    Standard

    Zitat Zitat von PeterHerbert1 Beitrag anzeigen
    Weißt du woran es mit der module.config liegen kann?
    Im „Normalfall“ steht in der Konfiguration nur ein einfacher Pfad:

    https://github.com/zendframework/Zen...config.php#L10

    Das ist nicht mal eine Framework-Eigenheit sondern blankes PHP. Wie sieht oder sah es da bei dir aus?
    Zum Zend Framework stehen jedem folgende Quellen zum Nachschlagen zur Verfügung:

Ähnliche Themen

  1. Controller und Plugins werden nicht eingebunden
    Von DerAnfang im Forum Einsteigerfragen
    Antworten: 12
    Letzter Beitrag: 22.05.2012, 12:06
  2. Controller Plugins werden nicht gefunden
    Von klangfeld im Forum MVC
    Antworten: 9
    Letzter Beitrag: 15.03.2012, 01:21
  3. [jQuery] Helper werden nicht gefunden
    Von el_coyotes im Forum Javascript + RIA
    Antworten: 3
    Letzter Beitrag: 12.01.2010, 01:39
  4. View Helper wird nicht gefunden
    Von luke the duke im Forum MVC
    Antworten: 8
    Letzter Beitrag: 04.04.2008, 03:10
  5. View Helper wird nicht gefunden
    Von hoompaloompa im Forum Einsteigerfragen
    Antworten: 11
    Letzter Beitrag: 27.03.2008, 15:22

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •