• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

email Adresse bleibt leer

stm_andreas

New member
Hallo!

Ich versuche Daten für ein Formular zur Bearbeitung aus der DB (postgres) auszulesen um das Formular damit zu befüllen.
Das funktioniert auch so weit, allerdings bleibt das Feld mit der email-Adresse immer leer. Alle anderen Felder die Sonderzeichen (Umlaute u.ä.) enthalten werden korrekt dargestellt.
Charset ist auf utf8 in DB und application.ini.
Beim Befüllen der DB funktioniert soweit alles, die email-Adresse wird auch brav in die DB geschrieben.

Hat jemand einen Hinweis für mich, wie ich das Problem beheben kann?
 

Kaiuwe

Super-Moderator
Willkommen im Forum! :)
Ich versuche Daten für ein Formular zur Bearbeitung aus der DB (postgres) auszulesen um das Formular damit zu befüllen.
Das funktioniert auch so weit, allerdings bleibt das Feld mit der email-Adresse immer leer. Alle anderen Felder die Sonderzeichen (Umlaute u.ä.) enthalten werden korrekt dargestellt.
Charset ist auf utf8 in DB und application.ini.
Beim Befüllen der DB funktioniert soweit alles, die email-Adresse wird auch brav in die DB geschrieben.

Hat jemand einen Hinweis für mich, wie ich das Problem beheben kann?
Wird sehr schwer, denn wir kennen leider deine Vorgehensweise nicht. Zeig doch mal bitte die relevanten Code-Auszüge hier kurz auf, ansonsten müssten wir anfangen mit Raten.
Interessant wäre, welche Daten an das Formular übergeben werden und wie. (Wie wird z.B. „setDefaults“ aufgerufen.)
 

stm_andreas

New member
Ich hab's gefunden ... wenn man im Mapper das Feld nicht mitgibt, kann es auch nicht ankommen ... ;)

Aber das hätte ich sicher noch 5 mal übersehen, hätte ich nicht den Code zusammensuchen müssen.
Danke jedenfalls. ;)

Andreas.
 
Oben