• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

Hosting bei Strato/Zend

spicy

New member
Hallo, und guten Abend,
ich suche einen Webhoster auf wechen ich ein Zend Projekt nutzen möchte.

Die Gute T-kom scheitert ja schon an .htaccess :confused::confused:

Meine Wahl viel auf Strato und diese teilten mir gerade am Telefon mit das Zend bei denen ohne Probleme läuft und verwendet werden kann.
Bzw. muss ich hier so einen Zend Optimizer verwenden ???

Hat hier jemand mit der Konfiguration und dem Einsatz von Zend bei Strato Erfahrung?

Seid so gut und lasst mich an euren Erfahrungen teilhaben ...

LG
 

Powers

New member
Hi spicy,

ich kann Deine Frage eigentlich nicht punktgenau beantworten, was bei Strato in Sachen ZF1 mit etwas Webspace ist.

Aber ich betreibe eine ZF2 Applikation auf einem kleinen V-Server von Strato. Vor knapp zwei Jahren hatte ich noch das Problem, dass das mitgelieferte Linux nicht die erforderliche PHP Version für ZF2 auswies. Habe daher alles selbst kompiliert.
Soweit ich weiß, ist das aber mittlerweile Geschichte und die heute verfügbaren Linux-Distributionen liefern mittlerweile PHP 5.4.15 mit, was voll ausreichend ist.

Meine Erfahrungen mit dem Strato-Support sind aber übrigens positiv. Die haben sich auch damals um eine Lösung bemüht, als die vorhandene PHP-Version bei mir nicht ausreichend war. Wenn die sagen, dass das Zf1 bei denen läuft, würde ich denen das sogar auch mal abnehmen. Nicht zuletzt habe ich schon Typo3-Installationen auf etwas Webspace laufen sehen und das Zend Framework 1 ist ja nun auch einfach PHP, welches schon lange nicht mehr up-to-date ist und eigentlich von jedem vernünftigen Betreiber lauffähig sein müsste.
 

Powers

New member
Wenn Du das sagst @up-to-date :)

Wollt damit nur ausdrücken, dass es auf jeder nicht völlig veralteten PHP-Maschine ja laufen sollte. Probleme mit der PHP Version tauchten bei mir erstmals mit dem ZF2 auf, dass mit Composer drum und dran einfach schon recht modern ist.

Dann gutes gelingen :cool:
 

spicy

New member
kleines Update von mir ...

Entgegen aller Befürchtung funktioniert es gleich auf anhieb, ohne irgendwelches Zutun!

Eine Frage habe ich aber noch - Gibt es eine Möglichkeit Zend_Captcha_Image ausserhalb des public Verzeichnisse erreichbar zu haben?

Die PNG Images, welche für das Captcha verwendet werden, werden erzeugt, jedoch nicht beim Client angezeigt.
Pfade/ Rechte sehen korrekt aus und sollten stimmen !
Ich würde es selber unschön finden, wenn diese mit im public Verzeichnis liegen müssen.

Ich denke es wird ein Rechteproblem beim Hoster sein, da es sonst ohne Probleme läuft ...
 

spicy

New member
Du weißt aber schon was „public“ heißt und was dies mit „der Client kann und muss sehen“ zu tun hat?! ;)
Ja, ich weis worauf Du hinaus möchtest!

Mich wundert nur das es auf meiner Linuxkiste läuft!?
hier habe ich neben public mein "data/captcha/*.png" liegen, welches so auch wunderbar erreichbar ist vom Client und sich somit nicht in public befindet

Werde dann wohl doch die Captcha Directory/Uri Pfad anpassen und auf den pulic Pfad legen ... :(
 

Kaiuwe

Super-Moderator
Mich wundert nur das es auf meiner Linuxkiste läuft!?
hier habe ich neben public mein "data/captcha/*.png" liegen, welches so auch wunderbar erreichbar ist vom Client und sich somit nicht in public befindet
Fehler in der Konfiguration bzw. auf deinem Testsystem nicht eingerichtet.

Werde dann wohl doch die Captcha Directory/Uri Pfad anpassen und auf den pulic Pfad legen ... :(
Der Smiley ist fehl am Platz. Der Client hat nur Zugriff auf den „public“-Ordner und nirgendwo anders. Alles andere wäre fatal!
 
Oben