• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

Installation der Skeleton App holt keine Abhängigkeiten

Frau Bauer

New member
Hallo,

ich möchte ein neues Projekt starten und gehe auf http://framework.zend.com/ma...

Dann gebe ich auf meinem Server ein:

Code:
php composer.phar create-project --stability="dev" zendframework/skeleton-application 01
cd 01
php composer.phar self-update
COMPOSER_PROCESS_TIMEOUT=5000 php composer.phar install
und erhalte

Code:
Loading composer repositories with package information
Updating dependencies (including require-dev)
Nothing to install or update
Generating autoload files
Er müsste doch aber eigentlich das Framework installieren? Warum Nothing to install?
 

Frau Bauer

New member
Ich habe des Rätsels Lösung gefunden. Einfach folgendes machen:

- in das Verzeichnis vendor/zendframework/zendframework der skeleton app wechseln
- dort composer installieren
- php composer.phar install ausführen

und schon wird das Framework gezogen.

So ist das aber nicht im Manual des Framework erklärt!
 

Frau Bauer

New member
Auch wieder wahr. Damit alle was davon haben und wir rausfinden können, was da faul ist, hier meine composer.json:

Code:
{
    "name": "zendframework/skeleton-application",
    "description": "Skeleton Application for ZF2",
    "license": "BSD-3-Clause",
    "keywords": [
        "framework",
        "zf2"
    ],
    "homepage": "http://framework.zend.com/",
    "require": {
        "php": ">=5.3.3",
        "zendframework/zendframework": "2.3.*"
    }
}
Danke!
 
Oben