• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

Internal Server Error (500er) -> sporadisch

screenminder

New member
Hallo in die Runde ...

ich nutze das Framework in der Version 1.12 (ja leider immer noch :)

Es funktioniert auch alles so wie es soll ... bis auf die kleinen sporadisch auftretenden 500er-Fehler.
Tritt ein solcher Fehler (beispielsweise beim Aufruf der Startseite) auf, reicht ein sofortiges Neuladen der Seite, um dann doch das gewünschte Ergebnis zu bekommen.
Es liegt also kein grundsätzlicher Fehler im Code vor, sonst würde ein Reload ja keine Abhilfe schaffen.

Hatte vielleicht jemand schon einmal so ein Problem ... oder hat vielleicht einfach so ne Idee, woran das liegen kann?
Oder wie ich aussagekräftige Fehlermeldungen bekommen kann (dann wahrscheinlich ja am ehesten Server-seitig)?

Ich danke vorab für eure Hilfe
 

screenminder

New member
So, ich habe die Logs mal das Wochenende über hoch-geschraubt und laufen lassen.
Wie vermutet, ist dort nichts ersichtlich. Sowohl im Zend-Logging, als auch auf dem Server.
Man sieht halt, dass er eine URL nicht bekommen konnte (500er) ... und im nächsten Moment (beim Reload) kriegt er sie dann doch.

Wir das ein Server-Problem sein? Ist der evtl. zu schwach, oderso?
 

Kaiuwe

Super-Moderator
So, ich habe die Logs mal das Wochenende über hoch-geschraubt und laufen lassen.
Wie vermutet, ist dort nichts ersichtlich. Sowohl im Zend-Logging, als auch auf dem Server.
Ich bin jetzt kein Serverspezialist, aber wenn in den Logs nichts zu einem Fehler 500 zu finden ist, dann scheint mir doch ein Fehler zu den Einstellungen bei den Logs zu geben.
 

zf2_timo

New member
Hallo screenminder,

ich hatte mal einen Fehler, auf den deine Fehlerbeschreibung passt.

Auf dem Server war der Wert für session.save_path auf /tmp gesetzt. Der Apache konnte hier auch ohne Probleme die Dateien ablegen und ändern.
Sobald aber die GarbageCollection ausgeführt wurde, um die abgelaufenen Sessions zu löschen gab es den Fehler, dass die Dateien nicht verändert werden dürfen.

Das Problem habe ich dann so gelöst, dass ich den session.save_path auf das Verzeichnis "/var/www/vhosts/xyz/tmp" gelegt habe.
Danach trat der Fehler nicht mehr auf.

Vielleicht ist das ja bei dir auch der Fall.

Gürße
 

screenminder

New member
Yeah ... das war offenbar das Problem.
Seit ich es umgestellt habe, habe ich keinen Internal Server Error mehr bekommen!

Vielen Dank für die tolle/schnelle Hilfe!
 
Oben