• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

Neuer Server Fehlermeldung The mysql driver is not currently installed in...

steffus

New member
Hi, ich habe ein Zend Projekt, welche ich jetzt auf einem neuen Server umziehen möchte. Auf diesem neuen Server wurde von mir php-fpm Version 7.2 installiert. Wenn ich jetzt das Projekt öffne, bekomme ich folgende Fehlermeldung:

Code:
Fatal error: Uncaught Zend_Db_Adapter_Exception: The mysql driver is not currently installed in
/var/www/html/.../library/Zend/Db/Adapter/Pdo/Abstract.php:112 Stack trace: #0 /var/www/html/.../library/Zend/Db/Adapter/Pdo/Mysql.php(109): 
Zend_Db_Adapter_Pdo_Abstract->_connect() #1 /var/www/html/.../library/Zend/Db/Adapter/Abstract.php(459): Zend_Db_Adapter_Pdo_Mysql-
>_connect() #2 /var/www/html/.../library/Zend/Db/Adapter/Pdo/Abstract.php(238): Zend_Db_Adapter_Abstract->query('SET NAMES 'utf8...', Array) 
#3 /var/www/html/.../application/Bootstrap.php(35): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES 'utf8...') #4 
/var/www/html/.../library/Zend/Application/Bootstrap/BootstrapAbstract.php(669): Bootstrap->_initDb() #5 
/var/www/html/.../library/Zend/Application/Bootstrap/BootstrapAbstract.php(622): Zend_Application_Bootstrap in 
/var/www/html/.../library/Zend/Db/Adapter/Pdo/Abstract.php on line 112

Wie kann ich das Problem lösen? Wäre für Hilfe recht dankbar.
 

Kaiuwe

Super-Moderator
Die Fehlermeldung ist hier doch recht eindeutig: „The mysql driver is not currently installed“ - es fehlt der Treiber für MySQL in PHP. Liest man etwas weiter, dann ist der Treiber für PDO gemeint. Das Problem liegt hier in der PHP-Installation.

Überprüfen lässt sich das Ganze mit der PHP-eigenen Funktion „phpinfo“. In der Übersicht sollte „pdo_mysql“ als eigener Abschnitt vorhanden sein.

Für die Installation siehe in der PHP-Dokumentation: https://php.net/manual/ref.pdo-mysql.php
 

Kaiuwe

Super-Moderator
Ich habe das Thema verschoben, denn es handelt sich um die Version 1 vom ZF und nicht Version 2.
 
Oben