• Willkommen im Zend Framework Forum

    ZF1 Zend Framework 1 + ZF2 Zend Framework 2

    Das Zend Framework Forum ist seit 2006 die erste Anlaufstelle für Zend Framework Entwickler in Deutschland. Mit über 70.000 Beiträgen und einer steigenden Nutzerzahl bietet das Forum hilfreiche Themen und ZF-Tutorials für professionelle Entwickler, fortgeschrittene Programmierer sowie Zend Framework Einsteiger.
    Wenn dies Dein erster Besuch in der Zend Framework Community ist, lies bitte zuerst die Hilfe - FAQ durch. Du musst Dich registrieren, bevor Du Beiträge verfassen kannst. Klicke oben auf 'Registrieren', um die Registrierung zu starten. Du kannst auch jetzt schon Beiträge lesen. Hier im Forum findest Du die Zend Framework Hilfe, die Du suchst!

    Grüße an alle Zend Framework Entwickler. Das Team vom Zend Framework Forum!

    Drupal Agentur

ZF1 - Problem phpunit

gingin

New member
Moin.

bin dabei mich mit Unit Tests anzufreunden ...
xampp 1.8.1
php 5.4.7
php.ini : include_path = ".;K:\xampp\php;K:\xampp\php\pear;K:\ZendFramework-1.11.11\library"

irgendwie bekomm ich in der obigen Version kein phpunit installiert.

Hat mir velleicht jemand nen Rat von euch ???

Code:
K:\xampp\php>pear install --alldeps phpunit/PHPUnit
No releases available for package "pear.phpunit.de/PHPUnit"
install failed

K:\xampp\php>pear channel-discover pear.phpunit.de
Channel "pear.phpunit.de" is already initialized

K:\xampp\php>pear install phpunit/PHPUnit
No releases available for package "pear.phpunit.de/PHPUnit"
install failed

K:\xampp\php>pear channel-discover pear.phpunit.de
Channel "pear.phpunit.de" is already initialized

K:\xampp\php>pear channel-discover pear.symfony-project.com
Channel "pear.symfony-project.com" is already initialized

K:\xampp\php>pear channel-discover components.ez.no
Channel "components.ez.no" is already initialized
Danke Gina

Zusatz:
mit früheren Installationen hat das mit der Installation von phpunit keine nennenswerten Probleme gegeben!

Lösung für obiges Problem:
pear cache gelöscht dann konnte ich mit 'pear uninstall phpunit/PHPUnit' und 'pear install --alldeps phpunit/PHPUnit'
 
Zuletzt bearbeitet:

gingin

New member
jetzt ist ein anderes Problem aufgetaucht:

...undefined method PHP_CodeCoverage_Filter::getInstance()

Code:
K:\xampp\htdocs\test\tests>pear list -c phpunit
INSTALLED PACKAGES, CHANNEL PEAR.PHPUNIT.DE:
============================================
PACKAGE            VERSION STATE
File_Iterator      1.3.3   stable
PHPUnit            3.7.10  stable
PHPUnit_MockObject 1.2.2   stable
PHP_CodeCoverage   1.2.7   stable
PHP_Invoker        1.1.2   stable
PHP_Timer          1.0.4   stable
PHP_TokenStream    1.1.5   stable
Text_Template      1.1.4   stable

K:\xampp\htdocs\test\tests>phpunit

Fatal error: Call to undefined method PHP_CodeCoverage_Filter::getInstance() in K:\xampp\php\phpunit on line 39
weiss da jemand Rat?
Danke Gina
 

Blub?

New member
Hi,

PHP_CodeCoverage ist auch die neueste Version oder noch von der vorherigen PHPUnit Version?
Channels, Pakete mal upgraden und evtl. "pear install --alldeps" zu PHPUnit versuchen.

Gruss
blub?
 

gingin

New member
Hi blub,

danke für dein feedback.

Nachdem ich xampp neu intstalliert habe, klappts jetzt auch mit phpunit. :rolleyes:
 
Zuletzt bearbeitet:
Oben